ECHR-KS Site - Search unavailable

Incident Report for ECHR Services

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 14:05 CEST

Update

We are continuing to investigate this issue.
Posted May 21, 2026 - 12:22 CEST

Investigating

We are currently investigating this issue.
Posted Apr 29, 2026 - 09:44 CEST
This incident affected: Knowledge Sharing (ECHR-KS).