HUDOC - Degraded Performance (Issue opening certain documents)

Incident Report for ECHR Services

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 10:31 CEST

Investigating

It is not possible to open certain documents published to HUDOC on Wednesday (28/05).
Posted May 30, 2025 - 16:10 CEST
This incident affected: HUDOC.